Search/download MusicVideo On Yahoo US,FR,AU,CA,DE,SP,UK

title says it all

Search/download MusicVideo On Yahoo US,FR,AU,CA,DE,SP,UK

Postby dgemily on Fri Dec 09, 2005 8:52 pm

Application built by The Lynx from the French team :


installation

- download and install Net Transport ( afree version is available there : http://www.gratilog.net/internet1.htm#nettransport)

- download XYahoo!Music :
http://www.france.xlobby.com/plugins/XY ... !Music.zip
(copy and past the link)

- unzip files in a same repertory :

Image

Configuration

Edit Config.ini :

[PARAMETRES]
DataBase = C:\Program Files\XlobbyFr\databases\rechercheclips.xml

[CLIPS]
NetTransport = C:\Program Files\Xi\NetTransport 2\NetTransport.exe
Enregistrersous = G:\CLIPS

[SON]
Debut = C:\Program Files\XlobbyFr\applications\CineHoraire\debut.wav
Fin = C:\Program Files\XlobbyFr\applications\CineHoraire\fin.wav

[XEVENT]
XalarmPath = c:\Program Files\XLobbyFr\plugins\XEvent\XAlarmeNow.txt
XEventCmd = xxx|CmdXevent2Vbs:refreshXEYahoo!Clips


PARAMETRES: indicate the xlobby database that you want create

CLIPS : path to NetTransport.exe and the repertory where you want save your music videos

SON : Debut = the audio file that you want execute at the stat of the search and Fin = for the end of the search

XEVENT : indicate the event that you want execute at the end of the search ( of course you need Xevent plugin

the application ( without xlobby)

you can also use the application without xlobby
you need this 3 files :
- Yahoo!Music 1.3.1.exe
- AutoItDLL.dll
- config.ini
then execute "Yahoo!Music 1.3.1.exe



Image

You can do a search on different Yahoo web sites

US = USA
FR = France
AU = Australia
CA = Canada
DE = Germany
ES = Spain
UK = United Kingdom

The option "Arborescence Xlobby" can give you a good structure of repertories in the aim of having an easy scan with xlobby . if this case is uncheck, all your files will be on the same repertory.

Make a search with the name of an artist , then click on 1 answer in the result list

In xlobby

screenshots are from Xmedia2-games skin.

1 –when there is any result.

Image

2 – make a search

Image

3 – result list.
At the first use the application will create a databases "rechercheclips.xml so you need to restart xlobby but only the first time

Image

4 – you can play the streaming file, or download files using net transport.

Image

5 - you can also make a search using your music database

Image

6 – you can use spiders to download covers: here are some :
- clips - album - yahoo.fr.zip
- clips - artist - yahoo.com.zip
- clips - artist - yahoo.fr.zip
- clips - title - fnac.com.zip
- clips - title - yahoo.com.zip

Image

Image

integrate the application in a skin


- using an "input button":
create un event "execute file" pointing to "Yahoo!Music.exe" and in arguments :

"%button>input%" "all"


"all" to make a search on every yahoo web sites, if you want for example make a search only on yahoo usa use : "usa"

- using your music database :
create un event "execute file" pointing to "Yahoo!Music.exe" and in arguments :

"%music>artist%" "all"


you can add a command "go to" in this event, in the aim of going on the result search

- to download a music-video
create un event "execute file" pointing to "Yahoo!Music.exe" and in arguments :

"%clips>parameter%"


where "clips" is the category to display the result (database rechercheclips.xml)

enjoy!
Member of XLobby FR Team
~~~~~~~~~~~~~~~~
Releases from the French team
dgemily
 
Posts: 795
Joined: Thu May 13, 2004 6:24 am
Location: Paris, France

Postby rika on Sun Dec 11, 2005 10:39 pm

Yes!!! another one from the french team!!
Thanks

Rika
rika
 
Posts: 403
Joined: Fri Apr 02, 2004 5:43 am
Location: Sweden

Postby rika on Mon Dec 12, 2005 2:09 pm

I can´t get the steaming to work (play the mms), downloads works perfect. Any trick to this?. Thanks

Rika
rika
 
Posts: 403
Joined: Fri Apr 02, 2004 5:43 am
Location: Sweden

Postby C-moi on Mon Dec 12, 2005 4:39 pm

I can´t get the steaming to work (play the mms)

did you try to play the streaming with Media Player Classic ?
File / Open File /
field Open : copy the mms link :wink:
Member of XLobby FR Team
Image
C-moi
 
Posts: 164
Joined: Fri Apr 23, 2004 6:58 am
Location: France

Postby rika on Tue Dec 13, 2005 9:09 am

Hmm, thats what i did... tryed mce, wmp and direct in explorer. Mce gives me somthing about that it can´t render or over zised the buffer. wmp says that it cant get to the file or that the proxysettings are wrong.

Tryed alot of different mms

Code: Select all
mms://dalwmod038.bcst.yahoo.com/bmfroot03/BMFShare03/__S__/launch.com/1/2272097.asf#StreamID=2272097&pl_auth=2f6401e8a6b5ec06ecfbdd1d2f00972e&ht=3630&xdata=nRzJb0G4ijlR1imAI0eTbg-219590-1888031798&pl_b=00CEBE2C2CD4251EAE7FC6865C439D1CCF&s=396500550/Prince%20-%20My%20Name%20Is%20Prince.wmv


Rika
rika
 
Posts: 403
Joined: Fri Apr 02, 2004 5:43 am
Location: Sweden

Postby dgemily on Wed Dec 14, 2005 11:52 pm

rika, the link has an expiration time, so now I can't see if your link is ok or not....
anyway try with MPC "media player classic" not wmp... that should work...
Member of XLobby FR Team
~~~~~~~~~~~~~~~~
Releases from the French team
dgemily
 
Posts: 795
Joined: Thu May 13, 2004 6:24 am
Location: Paris, France

Postby rika on Thu Dec 15, 2005 7:54 am

tryed mce, wmp and direct in explorer


Ops... should be mpc, I looked at the mpc forum and there is some people that have the same problem with .wma, asx, wmv (cant render the file) i´ll have to expremet with the mpc settings and see if i coluld solve this.
Thanks anyway.

Rika
rika
 
Posts: 403
Joined: Fri Apr 02, 2004 5:43 am
Location: Sweden

Postby dgemily on Thu Dec 15, 2005 9:01 am

ok,

maybe, try to add filters in mpc option, I'm not at home right now but if I remember, I have some filters activated. I will try to tell you which filters I have when I will go back to home.

Later,
Member of XLobby FR Team
~~~~~~~~~~~~~~~~
Releases from the French team
dgemily
 
Posts: 795
Joined: Thu May 13, 2004 6:24 am
Location: Paris, France

Postby rika on Thu Dec 15, 2005 7:12 pm

Thanks!
rika
 
Posts: 403
Joined: Fri Apr 02, 2004 5:43 am
Location: Sweden

Postby dgemily on Thu Dec 15, 2005 7:54 pm

I did a try without any "Overrides Filters" and it still working for me. so it's not the problem... sorry can't help you ...
did you try with another version of mpc ? to imform my tests was on the version 6.4.8.4

later
Member of XLobby FR Team
~~~~~~~~~~~~~~~~
Releases from the French team
dgemily
 
Posts: 795
Joined: Thu May 13, 2004 6:24 am
Location: Paris, France

Postby sagitaz on Thu Dec 15, 2005 10:45 pm

i have the same problem on my xlobby box and i try to install filter or codec and we don't forget the solution.

i think i install more codec pack and filter and desinstal this... and not work long time.

1 month ago, i format my xlobby box :twisted: , instal XP sp2 and all hotfix, don't install WMP 10, just wmp9 and i install the satsuki decoder pack 2.5.6.

now all off streaming video play and i don have problem. :lol:
Image
sagitaz
 
Posts: 114
Joined: Mon Jul 05, 2004 11:17 pm

Postby dalanik on Thu Feb 02, 2006 10:08 am

I have problem on 1 pc with this. I run Yahoo Music 3.x.x and it searches, but when i double click on a song, nothing happens even though I have NetTransport installed and correctly setup in config file. Any ideas?
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Postby dgemily on Thu Feb 02, 2006 5:59 pm

dalanik wrote:I have problem on 1 pc with this. I run Yahoo Music 3.x.x and it searches, but when i double click on a song, nothing happens even though I have NetTransport installed and correctly setup in config file. Any ideas?

you don't see any mms links ? did you try with more than 1 song ?
maybe you can try to watch a clip directly on yahoo web site ( http://music.yahoo.com/ ) maybe you have to get a cookie....
I know that there is something about a"mediah" but the programme should simulate a valid one....
Member of XLobby FR Team
~~~~~~~~~~~~~~~~
Releases from the French team
dgemily
 
Posts: 795
Joined: Thu May 13, 2004 6:24 am
Location: Paris, France

Postby dalanik on Fri Feb 03, 2006 10:24 am

dgemily wrote:
dalanik wrote:I have problem on 1 pc with this. I run Yahoo Music 3.x.x and it searches, but when i double click on a song, nothing happens even though I have NetTransport installed and correctly setup in config file. Any ideas?

you don't see any mms links ? did you try with more than 1 song ?
maybe you can try to watch a clip directly on yahoo web site ( http://music.yahoo.com/ ) maybe you have to get a cookie....
I know that there is something about a"mediah" but the programme should simulate a valid one....


Weird, I got it working on one PC, but not the other. I get the mms link, and when I double click, Yahoo Music closes and nothing happens.

But when I run search.bat it creates database, and I can copy and paste mms link ito net transport and it works....

I'll try logging onto yahoo music and see whether it helps.

Thanx,

Dalibor
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Postby dalanik on Fri Feb 03, 2006 10:46 am

No, it didn't help... :-(
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Next

Return to Tips and Tricks

Who is online

Users browsing this forum: No registered users and 1 guest

cron