Email Plugin???

V3 plugins

Email Plugin???

Postby smarty on Thu Jun 11, 2009 12:02 am

Does anyone have a working e-mail plugin? Does the xmail pluging from old still work (it doesn't seem to for me).

Xlobby seems to pretty well be my whole house user interface, but an e-mail plugin would be a great addition.
Elk M1, PowerHome, Insteon, GeoVision DVR, XLobby & SageTV
smarty
 
Posts: 206
Joined: Thu Jul 27, 2006 12:04 am
Location: San Antonio, TX USA

Re: Email Plugin???

Postby Jay on Thu Jun 11, 2009 12:50 am

Why not just launch the app?
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

Re: Email Plugin???

Postby S Pittaway on Thu Jun 11, 2009 6:33 am

because the email should be integrated within xlobby... :)

the old plugin sort of works, try resurrecting the thread and see if you can get it fixed.
S Pittaway
 
Posts: 713
Joined: Wed Jan 25, 2006 11:08 am
Location: Manchester, England

Re: Email Plugin???

Postby smarty on Fri Jun 12, 2009 5:10 pm

OK, I was doing some more testing with the Xmail plug-in from here http://www.xlobby.com/forum/viewtopic.php?f=14&t=4599&p=47426&hilit=xmail#p47426, and have found that this plug-in will work except for one indentifiable bug.

After you go through the alt-F2 plug-in set up process (to allow the plug-in to connect to and grab your e-mail) and populate the xmail.xml database for the first time, you will likley have problems when you go back and re-start Xlobby (I did).

What I found was that the xmail.xml database had a number of occurrences of improper "&" signs that cause the file to be an improper .xml file. Once you manaually strip out the "&" signs, the plug-in behaves as it was originally constructed.

Now, the question becomes, who can modify Mr. Dalibor Lanik's code (he should be asked if it is OK to use his plug-in in V3). I am NO programmer!!!!, just a lowly user.
Elk M1, PowerHome, Insteon, GeoVision DVR, XLobby & SageTV
smarty
 
Posts: 206
Joined: Thu Jul 27, 2006 12:04 am
Location: San Antonio, TX USA

Re: Email Plugin???

Postby S Pittaway on Mon Jun 15, 2009 8:23 am

if i had the code it would be an easy fix...

try bumping the thread?
S Pittaway
 
Posts: 713
Joined: Wed Jan 25, 2006 11:08 am
Location: Manchester, England

Re: Email Plugin???

Postby lar282 on Mon Jun 15, 2009 12:44 pm

I just downloaded it from
http://projects.lanik.org/
and tried it and I do not see the prob you described.
-----------------------------------
I set it all up in alt-F2
restarted
Got mail
restarted XL
All ok
-----------------------------------


//Lasse
Image
lar282
 
Posts: 1682
Joined: Thu Apr 01, 2004 4:13 pm
Location: Helsingborg, Sweden

Re: Email Plugin???

Postby smarty on Mon Jun 15, 2009 12:51 pm

I shot dalanik an ICQ message....hope he sees it.

The problem i described only happens with some of my e-mail messages. It seems that if the is an "&" sign in say the subject, or the e-mail To line is craps out. When I imported all my mail (maybe 50 emails), it only bombed on about 3-5 emails.

smarty
Elk M1, PowerHome, Insteon, GeoVision DVR, XLobby & SageTV
smarty
 
Posts: 206
Joined: Thu Jul 27, 2006 12:04 am
Location: San Antonio, TX USA

Re: Email Plugin???

Postby dalanik on Tue Jul 07, 2009 9:58 am

Will take a look at this, promise ;-) Been busy tweaking my GPS :-)
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: Email Plugin???

Postby smarty on Fri Jul 10, 2009 12:32 pm

Glad to see you back!!!
Elk M1, PowerHome, Insteon, GeoVision DVR, XLobby & SageTV
smarty
 
Posts: 206
Joined: Thu Jul 27, 2006 12:04 am
Location: San Antonio, TX USA


Return to Plugins

Who is online

Users browsing this forum: No registered users and 1 guest

cron