Page 1 of 1

Xlobby Stopped Working: Code CLR20R3 [resolved]

PostPosted: Sun May 06, 2012 7:44 pm
by gravy
Xlobby is crashing on startup fairly regularly lately for me. X completes all of the regular startup steps, and after the "Starting Xlobby.." step, it switches to my main screen but then throws this error:

xlobby_crash_CLR20r3.png


Is this a problem with my system, or is it something specific to xlobby? I've added a couple of buttons to my main screen in the past week, but nothing weird or new?

Thanks for any thoughts on how to troubleshoot this!


[edit - this was caused by the xoap-weather plugin. I was not actively using xoap-weather, but had accidentally left it in the xlobby/plugins folder. removing the xoap-weather directory appears to have solved this problem.]

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Sun May 06, 2012 8:10 pm
by gravy
Update: I checked the xlobby log and saw that my menu screen had a "enter event' associated with it - the xlobby action calls a girder event to get the current sunrise and sunset.

I recalled having problems before when I tried putting "enter events" on the main menu screen, usually resulting in xlobby crashing, so I"ve removed this "enter event" for now. Xlobby seems to be starting ok again now and will keep testing.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Sun May 06, 2012 11:49 pm
by Jay
xweather >current>show current displays sunrise and sunset.
You can drill down in that overlay to find and evoke the sunrise and sunset events wherever.
Hope that helps.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Mon May 07, 2012 1:25 pm
by gravy
Thx Jay, I'll use that.

Unfortunately, this xlobby crash and error code still occurs, just not as consistently. It happened again overnight - I woke up and X was displaying this "stopped working" window again.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Mon May 07, 2012 1:40 pm
by Jay
I assume this is your XL server crashing, not a client?

It sometimes happens to me if I add other server software to the same machine.
Add anything like that recently?

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Mon May 07, 2012 4:23 pm
by gravy
Yes, its my XL server machine. It is a multi-use server so unfortunately there are lots of things running concurrently. XL, Girder, and my whole-home audio services (Nuvo Technology). They've all worked in the past though, and I didn't make any updates to the other software. But you could be onto something there.

As for XL, I have made 2 recent changes:

1. Stephen implemented the ability to allow pop-up windows using the integrated browser, so I updated to the most recent bleeding edge version to test it.
2. I added 2 overlays to view my new IP cameras. At first, I tried using xlobby's "media player" action to play location> rtsp://192.168.x.x/play1.sdp, but then simplified it and just access the cameras via http / embedded web pages on Xlobby overlays.

I wonder if I left a media player "Play Location" event in there somewhere by accident. I'll have to keep a close eye on the xlobby log and see if I can correlate the crash time to a specific xlobby event.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Mon May 07, 2012 8:12 pm
by stevenhanna6
Check your xlobby folder for a file called "log-crashes-xlobby.txt", upload that if the times look right at the top it will help me track it down. I tried creating an enter event but I couldn't get it to crash, it's possible it is the enter event and you are trying to do something too early. Hopefully the log-crashes file is there.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Mon May 07, 2012 9:46 pm
by Jay
Oh. Yes, I remember something (?) I launched too early and it caused issues.

Re: Xlobby Stopped Working: Code CLR20R3

PostPosted: Tue May 08, 2012 12:44 am
by gravy
Hey Guys,

Thanks for the tip on the log-xlobby-crashes.txt file. That helped a ton! Here's the crash-log. It definitely coincides with the Stop error, and it was related to xoap-weather, which I no longer use and I thought I had uninstalled! I no longer use this plugin so I've deleted it. Hopefully that resolves things. I'll test for awhile and update the subject to [resolved] if so.

Thanks again gents!

Code: Select all
07/05/2012 7:36:58 PM
07/05/2012 7:36:58 PM
System.UnhandledExceptionEventArgs - Message: The remote server returned an error: (503) Server Unavailable. - Source: System - StackTrace:    at System.Net.HttpWebRequest.GetResponse()
   at System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials)
   at System.Xml.XmlDownloadManager.GetStream(Uri uri, ICredentials credentials)
   at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)
   at System.Xml.XmlTextReaderImpl.OpenUrlDelegate(Object xmlResolver)
   at System.Threading.CompressedStack.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.CompressedStack.Run(CompressedStack compressedStack, ContextCallback callback, Object state)
   at System.Xml.XmlTextReaderImpl.OpenUrl()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at XoapWeather.Provider.XoapProvider.GetDataFromServer(String locationID, String url)
   at XoapWeather.Provider.XoapProvider.GetForecast(String locationID, WeatherUnits units, Int32 days)
   at XoapWeather.Plugin.WeatherRegionForecast.UpdateFullForecast()
   at XoapWeather.Plugin.WeatherRegionForecast.Refresh()
   at XoapWeather.Plugin.WeatherPlugin.UpdateForecastsThread()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()