xLiveShout v1.2.1

Xlobby plugin development

Re: xLiveShout v1.2

Postby Jay on Tue Apr 29, 2008 12:20 pm

I compared several stations thru the plugin and ShoutCast.
These 3 behave differently on both.
Radyp derKi, Mazzoni Boundaries and Magnatude.com new age and ambient all time out after 2-3 seconds on the plugin. The musiccontrol overlay reports Busy, could not connect.
ShoutCast played thru Winamp works fine.

<add> these are in the Instrumental genre </add>
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

Re: xLiveShout v1.2

Postby defrag on Thu May 01, 2008 5:06 pm

OK I've seen this happen now... I put it down to the internal player. Winamp is fine.

Also I saw the audioplayer>now> variables go blank whilst a station was still playing - very wierd!!!

I will bump the existing defect post!!!
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2

Postby Jay on Thu May 01, 2008 6:01 pm

Agreed. And I saw your other post Re; the internal player & IP radio started by Smarty.
Image
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

Re: xLiveShout v1.2

Postby Marbles_00 on Sun Aug 03, 2008 6:00 am

Hey Defrag,

I haven't played around too much with xLiveShout lately. I've tried this on two computers now and I don't quite know if something has changed, or it could be me (though honestly, I haven't changed anything and it was working at one point). I've noticed now that when clicking on the genre category, the stations don't update, and only show all the available channels across multiple pages (2191 here :shock: )

Hopefully it won't be too hard to figure out.
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: xLiveShout v1.2

Postby defrag on Sun Aug 03, 2008 9:25 am

Heya Marbles

I'll take a look this week for you. Not had much time recently to play about with XLobby due to work commitments - but now you've given me an excuse :lol:
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2

Postby Marbles_00 on Sun Aug 03, 2008 7:04 pm

I've been reluctant on mentioning anything until I had a chance to try it on my test system...just because I haven't used it for a while, and no one else has mentioned anything...that's why I'm thinking I've done something.

*EDIT*
I think it may be my setup. I just tried my music-server (should have checked with that system first), and it is working. Sorry to have bothered you.
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: xLiveShout v1.2

Postby defrag on Sun Aug 03, 2008 9:26 pm

Marbles_00 wrote:I think it may be my setup. I just tried my music-server (should have checked with that system first), and it is working. Sorry to have bothered you.


No worries, always happy to be "bothered" :D
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2

Postby Marbles_00 on Mon Aug 04, 2008 1:11 pm

Yeah, I forgot to associate the get stations event to the cat. :lol: :oops: . All's working now.
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: xLiveShout v1.2

Postby defrag on Fri Sep 26, 2008 9:56 am

Hi All,

Look's like the Shoutcast page has been changed dramatically, which may be breaking this plugin at the moment. They have moved the old page to a new location - so I might be able to get away with just having a minor release to fix it over the weekend. Long-term though I'll have to have a look at their new interface to see what I can spider.

I'll keep you updated.

Defrag
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2.1

Postby defrag on Sat Sep 27, 2008 7:02 am

Plugin is now updated and points to classic.shoutcast.com and works as before.

The new page uses a lot of Ajax now - so a different strategy will be required if they decide to dump the classic view (I have it all planned!! :D ). But the new site is still in Beta and is still undergoing changes, so I will monitor and maybe look to upgrade (or provide 2 versions) when everything is stable.

Enjoy
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2.1

Postby scottw on Sun Sep 28, 2008 5:19 pm

Thanks for fixing that so quick. I use this plugin alot.
Scott
scottw
 
Posts: 777
Joined: Mon Feb 06, 2006 4:21 pm
Location: Glen Burnie, Maryland

Re: xLiveShout v1.2.1

Postby Jay on Sun Sep 28, 2008 5:22 pm

+1
Thanks!
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

Re: xLiveShout v1.2.1

Postby defrag on Sun Sep 28, 2008 5:34 pm

No worries!!! :D
XPro - The Widescreen 1360x768 Skin
xWOL2 - Wake On Lan Plugin with Network Monitoring
xLiveShout - Live Shoutcast Browser Plugin
My HTPC
Image
defrag
 
Posts: 379
Joined: Mon Jan 16, 2006 7:56 am
Location: Didcot, UK

Re: xLiveShout v1.2.1

Postby Jeroen on Tue Jan 20, 2009 9:31 pm

Since a couple of weeks, the plugin for xliveshout makes xlobby crash. i've tried a new install, on different pc's but program but no effect.
Anybody else with the same problem?
It always worked perfectly.
Jeroen
 
Posts: 12
Joined: Sat Nov 24, 2007 2:07 pm

Re: xLiveShout v1.2.1

Postby Jay on Tue Jan 20, 2009 10:37 pm

Just tried it on a commercial XL (ver. 2) and it's OK. Does it take a while to crash?
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

PreviousNext

Return to Plugins

Who is online

Users browsing this forum: No registered users and 3 guests

cron