Page 1 of 2

XMail plugin www

PostPosted: Tue Jul 04, 2006 8:01 pm
by dalanik
#
http://xlobby.lanik.org/XMail.jpg
##
XMail - E-Mail Integration (POP3, SSL) for XLobby
###

http://xlobby.lanik.org/XMail.v0.10b.exe

Any suggestions/comments welcome...

D.

PostPosted: Wed Jul 05, 2006 6:47 am
by dgemily
thanks, works fine out of there ;)

I tried on 2 accounts ....

is there anyway to configure 2 accounts or more at the same time ?

for everybody :
- of course you can not display html mail...
- don't worry if you want test, it will leave mails on the server ....

dalanik documentation wrote:To do:

• Configurator window, to allow you to specify server, username and password, without having to modify directly in registry.
• A way to alert user on new mail?
• SMTP? Let’s see if anyone wants to send mails from HTPC  Send me a mail if you do…

+1 lol

just one thing, for alert fonction, if you add it, make sure to give the possibility to disable and enable alert using an event or whatever you want, because I don't think is nice to get an alert when you are watching a movie...

later

PostPosted: Wed Jul 05, 2006 8:19 am
by dalanik
Yes, it leaves mail on the server... funny thing is that I wrote this for my google mail account - and that is the case it doesn't work well with - but the fault is entirely on google's side and how it handles email. On 2 other servers i tried it, it works fine. It, ofcourse checks google mail, but then google somehow marks those messages "read" and you can't download them via i.e. Outlook. It can either archive. delete or leave mails in inbox - but even when you set gmail to leave mails in inbox - you can't download them via outlook anymore :-(

well.. :-)

IMAP?

PostPosted: Wed Jul 05, 2006 1:55 pm
by timwarner
I thought the POP3 protocol always downloaded the mail. Does it depend on the ISP.

I use the IMAP protocol to access my mail from my smart phone or outlook on my laptop.

Will this plugin work for me?

I would love this feature it has been on my wish list for a while.

Re: IMAP?

PostPosted: Wed Jul 05, 2006 2:29 pm
by dalanik
timwarner wrote:I thought the POP3 protocol always downloaded the mail. Does it depend on the ISP.

I use the IMAP protocol to access my mail from my smart phone or outlook on my laptop.

Will this plugin work for me?

I would love this feature it has been on my wish list for a while.


Well, e-mail clients that use POP3 do download messages and then DELETE them from the server (as far as i know, please correct me if I'm mistaken). You can chose only to download and leave messages on the server. It shouldn't depend on the ISP, but mail server. That's why there are problems with gmail, because it doesn't behave the same way as "standard" email servers.

This should work for you if your server supports POP. You can check mails with this plugin and then read them or delete 'em with IMAP (or do whatever you like, since this plugin leavs mails on the server).

So, check if your server supports POP3 (it should).

D.

PostPosted: Wed Jul 05, 2006 7:08 pm
by dalanik
dgemily wrote:
just one thing, for alert fonction, if you add it, make sure to give the possibility to disable and enable alert using an event or whatever you want, because I don't think is nice to get an alert when you are watching a movie...

later


Yes, definitely. I'm still thinking whether to do it in plugin or leave it up to XEvent...

D.

PostPosted: Thu Jul 06, 2006 1:30 am
by Naylia
dalanik wrote:Yes, it leaves mail on the server... funny thing is that I wrote this for my google mail account - and that is the case it doesn't work well with - but the fault is entirely on google's side and how it handles email. On 2 other servers i tried it, it works fine. It, ofcourse checks google mail, but then google somehow marks those messages "read" and you can't download them via i.e. Outlook. It can either archive. delete or leave mails in inbox - but even when you set gmail to leave mails in inbox - you can't download them via outlook anymore :-(

well.. :-)


Holy crap!! I had no idea that google had POP3 support. You learn something new every day :)

PostPosted: Thu Jul 06, 2006 7:59 pm
by dalanik
dgemily wrote:- of course you can not display html mail...


As far as this is concerned, I can export HTML mail to a file, but I'm having problems displaying it... I still haven't figured what's not working, but there's something wrong with browser...

I.e. i tried putting the adress into %category>email>parameter% and setting "goto url", but it fails. I tried copying it to variable, it fails.

I tried passing the filename of the exported e-mail in C:\Program Files... or file:///Program%20Files... formats, it all fails....

has anyone tried displaying local html files in xlobby's browser?

D.

PostPosted: Thu Jul 06, 2006 10:14 pm
by dgemily
dalanik wrote:
dgemily wrote:- of course you can not display html mail...


As far as this is concerned, I can export HTML mail to a file, but I'm having problems displaying it... I still haven't figured what's not working, but there's something wrong with browser...

I.e. i tried putting the adress into %category>email>parameter% and setting "goto url", but it fails. I tried copying it to variable, it fails.

I tried passing the filename of the exported e-mail in C:\Program Files... or file:///Program%20Files... formats, it all fails....

has anyone tried displaying local html files in xlobby's browser?

D.


I already displayed a local html file, and made a thread on the french forum : http://www.xlobby-france.com/forums/ind ... wtopic=416

first I added a fake http link via le skin editor : screen->add misk->website
then edit the xml screen file and replace the link by my locale htm link

like (example):
Code: Select all
<imagename>http://xlobby.com</imagename>


by

Code: Select all
<imagename>file:///C:/Program%20Files/XlobbyFr/myMeteo.html</imagename>



so first you need to add an http link, then change it, so I didn't try but I think ( maybe) that we can't use directly the locale link using the command goto url.
( seem close to a bug isn't it? )

and I don't know how to manage it in your plugin.....

PostPosted: Thu Jul 06, 2006 10:47 pm
by dalanik
Yes, I did this too (changed http://google.com to local link) and it works, but not with goto URL...

hmm... maybe I can put in 1 local link, and the copy selected (file) e-mail over it...

PostPosted: Fri Jul 07, 2006 12:27 pm
by dalanik
Update; added mail checker. It uses internal timer to check for new mail every xx seconds, and there are 2 options; either display overlay when new mail is detected or run an event. For the second option, XEvent plugin is required.

D.

http://xlobby.lanik.org/XMail.v0.09b.exe

PostPosted: Tue Jul 11, 2006 9:44 pm
by dalanik
Update:

version 0.10 available. Same functionality, finally added configurator window, no more registry editing! :-) See first post for link.

D.

PostPosted: Tue Jul 25, 2006 1:56 pm
by dalanik
I've created links to plugin(s) and documentation on my site, so if anybody needs to have a peek at the plugin doc(s)....


http://xlobby.lanik.org

XMail documentation:

http://xlobby.lanik.org/XMail.htm

D.

Re: XMail plugin www

PostPosted: Tue Jun 10, 2008 7:57 am
by S Pittaway
dalanik,

i had a play with this last night and there seems to be a bug.

i am guessing you are writing your own xml file? because something is forgeting to replace the special xml chars (&, >, < etc)

if yor are creating your own xml files if you call this function with the tag body it will work fine


Code: Select all
    static public string XmlEncodeString(string XMLString)
    {
      XMLString = XMLString.Replace("\001", ".");
      XMLString = XMLString.Replace("\002", ".");
      XMLString = XMLString.Replace("\002", ".");
      XMLString = XMLString.Replace("\003", ".");
      XMLString = XMLString.Replace("\004", ".");
      XMLString = XMLString.Replace("\005", ".");
      XMLString = XMLString.Replace("\006", ".");
      XMLString = XMLString.Replace("\007", ".");
      XMLString = XMLString.Replace("\008", ".");
      XMLString = XMLString.Replace("\009", ".");
      XMLString = XMLString.Replace("&", "&amp;");
      XMLString = XMLString.Replace("<", "&lt;");
      XMLString = XMLString.Replace(">", "&gt;");
      return XMLString;
    }//XmlEncodeString

Re: XMail plugin www

PostPosted: Tue Jun 10, 2008 12:25 pm
by S Pittaway
also if you are in there could you add an extra 2 commands ? :)

CheckMailCommand
CheckerOnCommand

These can work in the same was as CheckMailEvent/CheckerOnEvent do but they simply trigger the command that is passed in.

This means you dont need to install xevent to trigger actions on an email.


Cheers, Sean.