Memory Usage ?

Xlobby plugin development

Memory Usage ?

Postby Bill Lott on Sat Feb 04, 2006 8:19 pm

I’ve have a problem that appears to be linked to the xAP plug-in. xLobby continues to use up memory over a period of a couple hours that renders my computer useless and with an out of memory error. xLobby usage begins at about 40,000K and grows every couple seconds until it uses up all the available memory on the machine.

I’m running Server 2003 with 512 of memory. If I remove the xAP plug-in, my system will remain stable for days. When I add the plug-in back, the memory problems occur.

I run Homeseer version 2 and xLobby with about 50 toggle switches to control Homeseer x10 lights.

I’ve tried rebooting, reloading, multiple copies, changing the order of loading programs and everything else I can think of sort of reformatting the hard drive. I thought originally it was winamp, but I’m now convinced my problem lies within the xAp plug-in on my system as I can wath memory usage and CPU numbers grow rapidly.

My system is running .net 2, the latest xLobby, xAP Plug-in version 3.0 and Homeseer xAP Conduit 2.0.301 interface using hspi_xAP2.ocx.

If I minimize xLobby while it is running I am able to reduce the memory usage temporarily, but after doing that a couple of times, the memory usage is even quicker than before.

I really want to get these programs working together, but over a couple hours time I have to shut down xLobby and reload in order to keep it going.

I really like the power of this plug-in and hope to be able to use it as ther front end of my automation system. I’m begging for ideas.

Thanks.
Bill Lott
 
Posts: 318
Joined: Sun Sep 05, 2004 3:25 pm
Location: Louisville, KY

Postby Jay on Sat Feb 04, 2006 11:12 pm

Scenario.
HS2 running on machine A.
XL with xAP3 and HubGUI running on machine B.

Have been anal about backups to CD.

Backed up today after adding just 2 events. HubGui was running, HS2 was running, XL had been terminated.

Finished backup and launched XL. xAP plugin was gone. This happened a lot after any XL change before I started using the HubGUI. Been using HubGUI for weeks with zero probs.

Tried an overwrite from the new backup cd. The prob had been transferred to the CD. I retrieved my last backup, copied over and all is well. I just need to recreate the last 2 events.

So, It wasn't HS2 because it's mi4.biz xAP plugin is strictly a client. XL was off and I don't THINK it leaves anything in RAM when dismissed. That's a question.
I believe the issh points to HubGUI not having been closed? Was it still looking for XL and somehow corrupted the supposedly dormant xAP3?

The most puzzling thing about this is the symptom is exactly as it was when I was using xAP3 as the hub - I run XL in Program Files and an identical copy is in a desktop folder for quick backup and for messing around.
Both lost xAP3 at the same time - just as they did when I used it as the hub.

I will add back the 2 missing events and kill HubGUI and XL before my next CD backup. (just used my last CD).

Any other ideas are appreciated before I do so.
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US

Postby Jay on Sun Feb 05, 2006 2:09 pm

Well, the copy on my desktop pointed to the duplicate in program files so no wonder it didn't work.

The lesson is to bring up HubGUI then HS2 and XL. Then before making backups or messing with XL, take down HubGUI 1st.

It also explains why my HS would not terminate properly. It was still connected to HubGUI.
Jay
 
Posts: 950
Joined: Thu Oct 13, 2005 6:28 pm
Location: Kiawah Island, SC US


Return to Plugins

Who is online

Users browsing this forum: No registered users and 2 guests

cron