X10 support?

Xlobby plugin development

Postby galtigor on Mon Jul 12, 2004 6:52 pm

Thanks Chicoo,

However I've done all of those things and I'm still having no luck.

Steve... I tried lauching Xlobby for debugging purposes with the pugin through the Visual Studio IDE. However when Xlobby starts it seems to hang.

I'll see about making my source code available for review (it's quite small). Maybe you can point me in the right direction.

Greg
galtigor
 
Posts: 31
Joined: Sat Feb 28, 2004 7:21 am
Location: Vancouver, BC, Canada

Stick with it!

Postby ukbubs on Mon Jul 12, 2004 9:00 pm

Galtigor

Just to let you know all your banging your head gainst the wall is much appreciated - I'll be getting my x10 out and learning how to use it within a couple of weeks - by which time you may have achieved your breakthough :D

Thanks for the good work!
ukbubs
 
Posts: 29
Joined: Tue Jun 29, 2004 6:46 am
Location: Suffolk, England

Postby Chicoo on Tue Jul 13, 2004 4:31 pm

Galigator

If you send your code to me I will review it for you and see if I can help you solve the problem. You can send it to me at: mailto:ome_coot@hotmail.com
Chicoo
 
Posts: 16
Joined: Wed May 12, 2004 6:24 pm
Location: Netherlands

Postby galtigor on Tue Jul 13, 2004 11:44 pm

Chicoo,

I've sent you my source code. If you can see any obvious problems just post the patch here and I'll update it.

Thanks,
Greg
galtigor
 
Posts: 31
Joined: Sat Feb 28, 2004 7:21 am
Location: Vancouver, BC, Canada

Postby Chicoo on Wed Jul 14, 2004 8:11 pm

Galtigator,

I send you an e-mail with the solution before I read through the forum, but I think that it is also usefull to others.

The problem is probably that the plugin cannot fins the x10Set.xml file. This is because the start the directory for the plugin is not the directory of the plugin, but the root directory of Xlobby.

If you have set the no path then it will search for the xml file in the root directory of xlobby. If you have set the path as e.g. plugins\filename.xml then it wil search for the file in the plugins directory.

So set the path in the code to directory of choice and place the xml file in the correct directory.
Chicoo
 
Posts: 16
Joined: Wed May 12, 2004 6:24 pm
Location: Netherlands

Postby galtigor on Wed Jul 14, 2004 9:10 pm

Chicoo,

Thanks for the suggestions.. I've sent you a response email and I'm afraid the changes didn't seem to make any difference.

Greg
galtigor
 
Posts: 31
Joined: Sat Feb 28, 2004 7:21 am
Location: Vancouver, BC, Canada

Postby galtigor on Thu Jul 22, 2004 8:48 pm

Bump!

I hope Steven can help me. I've tried everything I can think of. Chicoo has also been great help with this as well.

The lastest thing I've tried is removing all of the file manipulation code and just hard coded the settings for the plugin. However I still can't seem to get XLobby to recognize the .dll as a plugin. It does work with it's test app but it won't load into XLobby.

Any suggestions would be great... If you'd like to see the source let me know and I'll e-mail it to you.

Greg
galtigor
 
Posts: 31
Joined: Sat Feb 28, 2004 7:21 am
Location: Vancouver, BC, Canada

Postby stevenhanna6 on Fri Jul 23, 2004 8:24 pm

galtigor send me an email, I will try to help you out and I will give you access to the xlobby server you can upload your stuff there.

mailto:steve@xlobby.com
stevenhanna6
 
Posts: 934
Joined: Tue Feb 18, 2003 10:39 am
Location: Ontario, Canada

GREAT - Glad to see this is still in the works....

Postby kolemieux on Sat Jul 24, 2004 2:33 am

GREAT - Glad to see this is still in the works....

Thanks Steven
kolemieux
 
Posts: 155
Joined: Tue Jun 10, 2003 8:28 pm

Postby hjackson on Tue Sep 07, 2004 8:36 am

Where are we on the X10 plugin? Will it work with the CM11A device or just the firecracker?

hjackson
hjackson
 
Posts: 371
Joined: Sat Nov 29, 2003 7:12 am
Location: Tampa, Florida

Postby Aaron on Tue Sep 07, 2004 2:34 pm

One question gents...

There are so many X10 products out there (some free, some not), especically great ones like Homeseer which does so much more then just X10 for a small price, why not just build a plug-in for an existing package?

the whole reinvent the wheel thing?
Aaron
 
Posts: 302
Joined: Fri May 07, 2004 3:50 am

Postby hjackson on Tue Sep 07, 2004 6:32 pm

Well, it took less than 24 hours for someone at The Mecca (aka AVSforum) to answer my question about a commandline driven X10 program. It was right underneath my nose. There is an app (X10comm.exe) in the Active Home folder that allows for command lines. The syntax looks like this:
"C:\Progra~1\Home Control\x10comm.EXE" E1 Dim 080%
and this:
"C:\Progra~1\Home Control\x10comm.EXE" E1 Off
Once you've installed ActiveHome, you can just go ahead and write commands. The other good thing about ActiveHome, is that it is easily accessible for purchase at Radio Shack or Lowes.
Good luck guys.

hjackson
hjackson
 
Posts: 371
Joined: Sat Nov 29, 2003 7:12 am
Location: Tampa, Florida

Postby theendisnye on Tue Sep 07, 2004 8:20 pm

ActiveHome can be downloaded here

http://www.x10.com/support/support_soft1.htm

I used XPL which gives me command line entry. XPLHAL then provides scheduling and some simple if this then logic. e.g. if the weather is fine (from weather.com) then switch on the fan (swithch on unit A1)

Steve
theendisnye
 
Posts: 18
Joined: Wed Jun 09, 2004 1:39 pm

Postby galtigor on Tue Sep 07, 2004 8:26 pm

Sorry I haven't posted in a while.. been busy at work and then Steven's server got hosed. I'm going to upload the source code for Steven to take a look at. Last time I worked with it I got it to load into XLobby but then it wouldn't actually do anything with my X10 modules.. It does work when it's run from a test program outside of XL but not within it.

Greg
galtigor
 
Posts: 31
Joined: Sat Feb 28, 2004 7:21 am
Location: Vancouver, BC, Canada

Postby TonyNo on Wed Sep 08, 2004 12:59 am

Affini strikes a chord with me. I would think that HomeSeer would support Windows Messaging (I use a program called PowerHome for my X10 stuff and it does). Is there a down-side to doing it this way?
TonyNo
 
Posts: 13
Joined: Mon Sep 06, 2004 4:49 pm

PreviousNext

Return to Plugins

Who is online

Users browsing this forum: No registered users and 2 guests

cron